JSM's Non-Breaking Space for French Content

Deskripzioa

This plugin adds non-breaking spaces required by the French language in the content, excerpt, comments, text widget, and WooCommerce short description – skipping over pre-formatted code blocks, styles and scripts.

If the <!--:fr--> HTML tag is found (used by some multilingual plugins), non-breaking spaces are added only between the <!--:fr--> and <!--:--> HTML tags.

There are no plugin settings – simply install and activate the plugin.

Berrikuspenak

2022(e)ko irailaren 22(a)
Allô JS Morissette, Merci de ton plugin Ça marche bien dans Wordpress. mais saint-simonac, y marche pas dans Elementor !!! Câline de bine C'est tu bhen compliqué de le faire fonctionner dans Elementor ? Je dois certainement pas être le seul à être francophone + qui utilise Elementor + qui a un devoir de faire marcher une page web avec une typo qui's'tien d'boute bref Au plaisir de te lire si tu passes à l'action chu même prêt à payer un ti-montant, genre moins de 50$ 😉 Amitiés Marc
2022(e)ko uztailaren 13(a)
Bonjour, je suis déçu. J'utilise l'éditeur Elementor et le thème OceanWP dans ce contexte, le plugin ne place pas d'espace insécable ! Est un problème corrigeable par le concepteur ? Par ailleurs, pour ceux chez qui ça fonctionne, le plugin met-il des espaces insécables comme séparateur des milliers, là où j'ai souligné_: 2_320_000_? Robert.
2020(e)ko azaroaren 12(a)
Bravo ! J’avais l’habitude d’utiliser Automatic NBSP mais il fait planter les formulaires Gravity Forms utilisés avec Elementor. Je viens d’installer cette extension et hop, ça marche sans problème. En réponse à un commentaire posté plus bas : il n’y a rien à faire ! Il faut écrire normalement, c-a-d laisser une espace avant les signes de ponctuation de double hauteur. L’extension ajoutera automatiquement une espace insécable à l’affichage. Rien n’apparaît lors de l’écriture du texte. Encore merci au développeur de cette extension.
2020(e)ko urriaren 22(a)
L'extension remplit parfaitement son rôle. L'insertion des espaces insécables s'effectue automatiquement dès que le plugin est installé. Il n'y a rien à faire côté éditeur (Gutenberg avec version WP 5.5.1). Toutes les publications effectuées avant l'activation de l'extension bénéficient des correctifs. Good job ! Thanks (merci beaucoup) 😉
2020(e)ko abuztuaren 31(a)
Je ne comprends pas, ça ne fonctionne pas. Est-ce que l'insécable est censé apparaître au cours de la frappe ? Ou bien quand on enregistre l'article ? Est-ce qu'il faut taper le signe de ponctuation collé au mot pour que l'insécable soit inséré ? Ou bien on met une espace normale et l'extension la remplace par un insécable ? J'ai l'impression d'avoir tout essayé et rien ne change. Ca manque de documentation pour expliquer comment ça marche... Ma version de Wordpress : 5.5–fr_FR
Irakur itzazu 12 berrikuspen guztiak

Laguntzaileak eta Garatzaileak

“JSM's Non-Breaking Space for French Content” software librea da. Ondoko pertsonek egin dizkiote ekarpenak plugin honi.

Laguntzaileak

JSM's Non-Breaking Space for French Content 1 eskualde-ezarpenera itzuli da. Eskerrik asko itzultzaileei beraien ekarpenengatik.

Itzul zaitez JSM's Non-Breaking Space for French Content zure hizkuntzara.

Garapena interesatzen zaizu?

Araka ezazu kodea; begira ezazu SVN biltegia, edo harpidetu garapen erregistrora RSS-(r)en bidez.

Aldaketen loga

Version Numbering

Version components: {major}.{minor}.{bugfix}[-{stage}.{level}]

  • {major} = Major structural code changes and/or incompatible API changes (ie. breaking changes).
  • {minor} = New functionality was added or improved in a backwards-compatible manner.
  • {bugfix} = Backwards-compatible bug fixes or small improvements.
  • {stage}.{level} = Pre-production release: dev < a (alpha) < b (beta) < rc (release candidate).

Repositories

Changelog / Release Notes

Version 1.12.0 (2020/10/20)

  • New Features
    • None.
  • Improvements
    • Added a non-breaking-space between parentheses and punctuation.
  • Bugfixes
    • None.
  • Developer Notes
    • None.
  • Requires At Least
    • PHP v7.2.
    • WordPress v5.2.